Webmail is not loading
Incident Report for Onlinesoft Pty Ltd
Resolved
This incident has been resolved.
Posted Jun 09, 2023 - 15:04 AEST
Investigating
We are currently investigating why our webmail is not loading.
Posted Jun 08, 2023 - 17:01 AEST
This incident affected: Mail Servers (Openmail).